On the off chance that you are deploying Ruby apps as Java Servlets using JRuby/Warbler, beware of recent releases of Bundler. Bundler 1.10.0 came out this past Sunday (May 28, it looks like), and it doesn’t play nicely with Warbler. The failure happens when you first use Bundler >= 1.10 to build a dependency tree prior to running warble, whereupon warble blows up with a distinctive error message like ArgumentError: dependency name must be a String, was #<Bundler::StubSpecification:0x1e69dff6. …